Commit 0f909118 authored by Adrien Dorsaz's avatar Adrien Dorsaz

gitlab-ci: try to use smaller images and avoid install recommends

parent a8661b1e
Pipeline #230 canceled with stage
......@@ -4,11 +4,11 @@ RUN apt-get update
RUN apt-get upgrade -y
# Minimal tools required by acme-dns-tiny CI
RUN apt-get install -y \
RUN apt-get install -y --no-install-recommends \
python3-coverage \
python3-pip
RUN apt-get install -y \
RUN apt-get install -y --no-install-recommends \
-t jessie-backports \
python3-configargparse \
python3-dnspython
......
FROM debian:jessie
FROM debian:jessie-slim
RUN apt-get update
RUN apt-get upgrade -y
# Minimal tools required by acme-dns-tiny CI
RUN apt-get install -y \
RUN apt-get install -y --no-install-recommends \
python3-dnspython \
python3-coverage \
python3-pip
......
FROM debian:stretch
FROM debian:stretch-slim
RUN apt-get update
RUN apt-get upgrade -y
# Minimal tools required by acme-dns-tiny CI
RUN apt-get install -y \
RUN apt-get install -y --no-install-recommends \
python3-dnspython \
python3-coverage \
python3-configargparse \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment